Jump to content

Search the Community

Showing results for tags 'Fittings'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Read before you register
    • Forum News
    • New Board Issues
  • New Work
    • Show and Tell
    • Photography
    • Video and Multimedia
    • Knives For Sale
    • Design and Critique
  • Old Work
    • History
    • Old Masters
    • Library
  • Forge Work
    • Hot Work and Bladesmithing
    • Hot Work
    • Bloomers and Buttons
    • Beginners Place
    • Teacher Directory
  • Forges, Tools, Equipment and Materials
    • Tools and Tool Making
  • Finishing, Tips and Tricks
    • Fit and Finish
    • Sheaths and Leatherwork
    • Carving and Applied Arts
    • Shop Safety
    • Non-Ferrous: fittings, alloys, patinas
  • Heat Treating
    • Metallurgy and other enigmas
    • Heat Treating by Alloy
  • Events
    • Events of Interest
  • Discussion
    • The Way
    • Fiery Beards
    • Books, Videos, and other Media
  • Tailgate Sales
    • Tools, Supplies and Materials
  • Hall of Fame
    • Nominations
    • Show and Tell Hall of Fame
    • WIP/Tutorial Hall of Fame
  • Pinned Topics
    • Pinned Show and Tell
    • Pinned Hot Work Topics
    • Pinned Buttons and Bloomers
    • Pinned Tools and Toolmaking
  • Maker's Mark Registry
    • Maker's Mark Registry
    • Marks to be Identified
  • KITH
    • KITH 2011-2019
    • Christmas KITH 2019
    • KITH 2020

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I have been working on a project that is without doubt my best work thus far (no spoilers yet!) but ran into a snag with casting the fittings. I already carved the wax, made a silicon mold of it and a few copies. That all went fine, and actually came out better than expected. However, after setting it in investment, the bronze well, failed miserably. I had a small sprue vent to help the air escape, and that filled about half way before a void the size of the thing I was casting formed between it and the top of the flask. Is this because the bronze was too cold? Or the mold not preheated enough? Any advice would be greatly appreciated. Hopefully, I'll be able to give it another go this afternoon. Thanks John (Large cone part was the top of the mold, thin wiry thing the vent, and the bit on the end of it being the bottom part of what I was trying to cast)
×
×
  • Create New...